Der CNC-Thread

Seite 14 von 15 ErsteErste ... 1112131415 LetzteLetzte
  1. #131
    Teil der Gemeinde Avatar von Andreas
    Real Name
    Andreas
    Dabei seit
    Sep 2003
    Beiträge
    126
    Hi Martin,

    ich weiß, dass der Dennis mehrere Vakuumtische auf seiner Maschine hat. Selber habe ich mich mit dem Thema noch gar nicht befasst.

    Nach 4 langen Tagen, bin ich nun fast fertig. Die Verkabelung ist komplett, alle Sensoren haben Ihren Platz gefunden und eine grobe Konfiguration in der Steuerungssoftware ist auch durch. Maschine läuft!

    Einzig der Werkzeuglängensensor fehlt noch und ein paar Fräser.
    Hier der aktuelle Stand in Bildern:

    IMG_2131.jpg

    IMG_2136.jpg

    IMG_2140.jpg

    IMG_2141.jpg

    Kein Kabel berührt den Boden....

    IMG_1912.jpg

    .....außer die Pneumatik liegt noch etwas lieblos auf dem Boden rum. Hierfür will ich aber erst ein Gestell bauen, wenn ich mich für eine Minimalmengenschmierung entschieden habe. Derzeit ist eine Noga verbaut, ich glaube aber nicht das die bleibt.

    IMG_2128.jpg

    Damit die Referenzsensoren richtig passen, habe ich mir ein Paar Adapter aus Edelstahl gedreht...

    IMG_2088.jpg

    IMG_2089.jpg

    Auch sonst waren noch relativ viele Fräs und Drehteile nötig, damit die Referenzschalter richtig positioniert werden konnten. Davon habe ich aber keine Bilder gemacht.

    Als nächstes steht das Bohren des Tisch an. Das Program ist hierfür schon fertig, aber ich will auf den WLS warten und es fehlt auch noch ein Fasenfräser.

    Frästisch v23.jpg

    IMG_2142.jpg

    Das wars erstmal....Viele Grüße!


  2. #132
    Teil der Gemeinde Avatar von Andreas
    Real Name
    Andreas
    Dabei seit
    Sep 2003
    Beiträge
    126
    Meine Ersten CNC Späne (unten gibt es Links zu den Videos)

    80 Bohrungen M8 Kernloch, 20mm tief. Matetrial ist 1.1730 C45W Werkzeugstahl. Ohne Pause und bis zum letzten Loch wie in Butter.

    Erst angebohrt....

    IMG_2183.jpg

    Danach gebohrt und gefast...

    IMG_2199.jpg

    IMG_2200.jpg

    Bohren:

    https://youtu.be/erTgLPTakjo

    Fasen (hier hat das CAM mir den Eilgang verweigert, aber ich hab ja Zeit ):

    https://youtu.be/uFiqYFcylYM

    Schönes Wochenende....


  3. #133
    Teil der Gemeinde Avatar von Andreas
    Real Name
    Andreas
    Dabei seit
    Sep 2003
    Beiträge
    126
    Obwohl das Interesse hier doch eher begrenzt ist, zumindest zeigen das die Youtube Klick Stats, mache ich mal weiter mit meiner kleinen Projekt Doku.
    Nach den ersten Testfräsungen haben sich ein paar Baustellen aufgezeigt, welche das gesamte Projekt erstmal gestoppt haben.

    Erstes und größtes Problem sind die JMC Schrittmotoren. Ich habe bereits die zweit größten gewählt, aber funktioniert haben die Dinger überhaupt nicht. Alle Achsen ließen sich mit relativ wenig kraft um 1/10 verschieben. Haltemoment quasi nicht vorhanden. Demensprechend sahen dann auch die Fräsergebnisse aus. Katastrophal. Beim Versuch die Parameter über die Schnittstelle anzupassen, sind dann auch gleich mal 2 von 3 JMCs ins Jenseits gewandert.
    Nach Rücksprache mit den Shop, scheint das kein Einzelfall gewesen zu sein und das anpassen der Parameter sollte eigentlich nicht nötig sein.
    Egal, bevor ich mich weiter mit dem JMC Mist rumärgere, fliegt das Zeug wieder raus. Der Kontakt zu Dold, wo ich die Motoren gekauft habe, war hier aber bisher exzellent! Eine Ersatzlieferung, mit anderen Komponenten, ist bereits auf dem Weg zu mir und die Stepper gingen heute zurück zu Dold.

    Wenn das am Ende wirklich alles Funktioniert, muss ich ein großes Lob an Dold aussprechen, denn der Support war wirklich erstklassig. Auch noch mal speziellen Dank an Dennis, der mir die ganze Zeit mit Rat und Tat zur Seite steht.

    In der Zwischenzeit habe ich es auch geschafft 80 Gewinde zu schneiden und diese mit Maden wieder zu verschießen. Ein temporärer Späneschutz ist auch eingezogen.

    IMG_2266.jpg

    IMG_2255.jpg

    IMG_2259.jpg

    IMG_2261.jpg


  4. #134
    Teil der Gemeinde Avatar von Maad
    Real Name
    Marek
    Dabei seit
    Feb 2009
    Beiträge
    190

    Ich verfolge dein Treiben mit Interesse, ich habe es nur noch nicht so gezeigt.

  5. #135
    Teil der Gemeinde Avatar von psyke
    Real Name
    Stefan
    Dabei seit
    Oct 2010
    Beiträge
    3.187
    Wir nutzen auch die Jmc-Motoren.

    Die MUSS man parametrieren, die sind katastrophal schlecht voreingestellt. Wir haben da erstmal ein Setup erstellt, dass läuft, aber wir stellen nochmal ein, messen den Strom, sehen uns auf dem Oszi die Signale an und stellen so lange ein, bis der Schleppfehler minimiert wird. Im Grunde besitzen die Servos genug Haltemoment, die Regelung ist aber so träge, dass man sie von Hand ein Stück drehen kann, sie dann den Positionsfehler bemerken und dann erst regeln.

    Wir arbeiten derzeit an LinuxCNC auf dem Rasberry 4, verfahren und Homing läuft, Rest müssen wir noch implementieren. Lagerspiele einstellen etc. Irgendwann soll auch per Modbus der FU ausgelesen werden, dann kann die Spindellast in LinuxCNC angezeigt werden.

    Hab schonmal einen Absaugschuh mit Magneten konstruiert, ein 24" Touchscreen und 3D - Taster stehen hier auch schon.

    Gesendet von meinem SM-G985F mit Tapatalk

  6. #136
    Teil der Gemeinde Avatar von Andreas
    Real Name
    Andreas
    Dabei seit
    Sep 2003
    Beiträge
    126
    Zitat Zitat von Maad Beitrag anzeigen
    Ich verfolge dein Treiben mit Interesse, ich habe es nur noch nicht so gezeigt.
    Danke



    Zitat Zitat von psyke Beitrag anzeigen
    Wir nutzen auch die Jmc-Motoren.
    Aber ihr nutzt die Servo Motoren, oder? Ich hatte die Schrittmotoren im Einsatz. Das die Servos eingestellt werden müssen, ist klar. Das ist dann auch eine komplett andere Software von JMC. Bei den Stepper Motoren gibt jeder an, dass diese nicht konfiguriert werden müssen.
    Ich hätte auch kein Problem damit diese einzustellen, wenn die nicht dabei kaputt gehen würden. Ich habe das Vorgehen beim Parameter setzen auch mit Dold genau durchgesprochen und wir haben hier definitiv nix falsch gemacht. Auch bin ich nicht der erste mit dem Problemchen

    Egal, nächste Woche kommt Ersatz und ich bin schon dabei die Steuerung dementsprechend umzubauen.


  7. #137
    Teil der Gemeinde Avatar von psyke
    Real Name
    Stefan
    Dabei seit
    Oct 2010
    Beiträge
    3.187
    Oh sorry, das hatte ich überlesen und direkt an unsere Probleme mit den Dingern gedacht. Warum denn nicht die Servos?

    Gesendet von meinem SM-G985F mit Tapatalk

  8. #138
    Teil der Gemeinde Avatar von Andreas
    Real Name
    Andreas
    Dabei seit
    Sep 2003
    Beiträge
    126
    Zitat Zitat von psyke Beitrag anzeigen
    Warum denn nicht die Servos?
    Gut Frage Ich habe da ehrlich gesagt auf Empfehlungen gehört und mir dann die Vor und Nachteile von Schrittmotoren etwas zusammengelesen.
    Der Hauptgrund ist die Einfachheit der Stepper. Bei Servos sehe ich mich schon mehr Tunen als fräsen Auch glaube ich, dass die Vorteile von Servos bei mir nicht 100% zum Tragen kommen. Durch 10mm Spindelsteigung, 1 zu 1 übersetzt, benötige ich nicht viel Drehzahl und die Drehmomentkurve der Stepper passt ziemlich perfekt in mein Bearbeitungsfenster. Die Geräusche der Stepper sind eher nebensächlich, weil die gesamte Anlage an sich schon relativ laut ist und bei den möglichen Zustellungen, übertönt die Spindel eh alles Andere.
    Kosten spielen da aber auch eine Rolle. Der Maschinenhersteller verbaut 700W Servos auf allen Achsen. Das ist dann aber preislich eine ganz andere Liga. Ich bin leider jetzt schon fernab von jedem ursprünglich gesetztem Budget.

    Jetzt versuche ich mein Glück mit Sanyo Denki Schrittmotoren und Leadshine Endstufen.

    2. Baustelle ist der fehlende Bremswiderstand am FU. Bei geringen Drehzahlen bis 10.000 Umdrehungen ist das kein Problem. Über 10.000 Umdrehungen schafft es die interne Bremse des FU nicht mehr. Ich musste die Rampenzeit auf 20Sek stellen, sonst läuft der FU in einen Fehler beim Stoppen der Spindel. 20Sek sind natürlich auch sicherheitstechnisch eine Katastrophe. Also muss erstmal ein Bremswiderstand her.

    Grüße


  9. #139
    Teil der Gemeinde Avatar von Andreas
    Real Name
    Andreas
    Dabei seit
    Sep 2003
    Beiträge
    126
    Heute sind die neuen 2 von 3 Motoren und alle Endstufen gekommen. Zum Glück hatte ich noch ein exakt passenden Platz im Schaltschrank.

    IMG_2290.jpg

    IMG_2291.jpg

    IMG_2298.jpg

    Der Unterschieg ist fast schon unglaublich. Bei 30m/min Vorschub und einer Beschleunigung von 2.500mm/s² habe ich für heute aufgehört. Da geht sicherlich deutlich mehr, aber bei 2.800mm/s² hat mein Untergestellt angefangen zu hüpfen. Sobald da aber mehr Gewicht drauf kommt, sollte 3.500 das Ziel sein. Mit den Alten Motoren war bei 12m/min Vorschub und 430mm Beschleunigung Schluss. Darüber wurden diese so unkontrolliert, dass es sich nicht mehr Gesund angehört hat.
    Auch die Achsen sind jetzt bomben fest und das quasi "Out of the Box" ohne tuning.

    Glücklich


  10. #140
    Teil der Gemeinde Avatar von Stefan dämmt
    Real Name
    Stefan
    Dabei seit
    Feb 2019
    Beiträge
    419
    Allgermeiner Fan von Bearbeitunmgszentren mit Power +1

Seite 14 von 15 ErsteErste ... 1112131415 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •